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เอกสารประกอบการสอน
โปรแกรม DreamweaverMX

Dreamweaver เป็นเครื่องมือในการสร้างเว็บเพจและพัฒนาเว็บไซต์ที่มีประสิทธิภาพสูง เป็นผลิตภัณฑ์ของบริษัท Marcromedia เราสามารถที่จะออกแบบและพัฒนาเว็บไซต์ด้วยการเขียนโค๊ดภาษา HTML หรือจะใช้เครื่องมือจากที่โปรแกรม Dreamweaver มีให้ ซึ่งเครื่องมือเหล่านี้จะสร้างโค๊ดภาษา HTML ให้เราโดยอัตโนมัติ โดยที่เราไม่จำเป็นต้องเขียนโค๊ดภาษา HTML เอง
เราจำป็นต้องเรียนรู้ภาษา HTML ไหม?
เว็บเพจเป็นการรวบรวมข้อมูล รูปภาพ และเนื้อหาด้านมัลติมีเดีย โดยส่วนใหญ่จะสร้างจากภาษา HTML เราจะเห็นว่าการสร้างเว็บเพจนั้นมีความสำคัญมาก ซึ่งการเรียนรู้ภาษา HTML จะช่วยให้เราเข้าใจถึงโครงสร้างเว็บเพจแต่ละส่วนได้เป็นอย่างดี แม้ Dreamweaver จะช่วยให้เราสามารถสร้างเว็บเพจได้โดยไม่ต้อมีความรู้ด้าน HTML เลย เพราะโปรแกรมเหล่านี้จะสร้างโค้ด HTML ให้กับเราโดยอัตโนมัติ อย่างไรก็ตาม หากเราต้องการแก้ไขบางอย่างในเว็บเพจที่สร้างเป็นการเจาะจง บ่อยครั้งเราจะพบว่าโปรแกรมเหล่านี้จะไม่สามารถทำในสิ่งที่เราต้องการได้ ในกรณีเช่นนี้ หากเรามีความเข้าใจเกี่ยวกับภาษา HTML ก็จะเป็นประโยชน์อย่างมาก เพราะทำให้เราเข้าไปแก้ไขโค้ด HTML ที่ใช้สร้างหน้าเว็บเพจนั้นได้เองโดยตรง นั่นหมายความว่าความเข้าใจด้าน HTML นอกจากจะช่วยให้เราเข้าใจหลักการทำงานของเว็บแล้ว ยังช่วยให้เราสามารถควบคุมการสร้างเว็บเพจได้โดยไม่ถูกจำกัดใด ๆ 
ความสามารถของโปรแกรม Dreamweaver MX
Dreamweaver เป็นเครื่องมือที่ใช้งานได้ง่าย คล้ายกับโปรแกรมประเภทเดียวกับ FrontPage, NetObject Fusion, HomeSite, HotDog  ซึ่งเพียงแค่เราใช้งานโปรแกรมคอมพิวเตอร์ ทั่วไปได้และแค่ลากองค์ประกอบของหน้าเว็บเพจที่ต้องการ (เรียก Object ) ไปวางบนหน้าเอกสาร ดัดแปลง รูปแบบต่าง ๆ ดังวิธีการในหนังสือเล่มนี้ เท่านี้เองเว็บเพจที่คุณออกแบบก็สามารถไปปรากฏบนเครือข่ายอินเทอร์เน็ต ให้ผ่านสายตานักท่องเว็บได้แล้ว
สำหรับท่านที่กำลังตัดสินใจว่าจะใช้โปรแกรม Dreamweaver เป็นเครื่องมือในการสร้างเว็บเพจหรือไม่ ให้เราลองมาพิจารณาความสามารถโดยรวมของ Dreamweaver กันก่อน
1. สนับสนุนการทำงานแบบ WYSIWYG (What You See Is What You Get) หมายความว่าอะไรก็ตามที่เราทำบนหน้าจอ Dreamweaver ก็จะปรากฏผลแบบเดียวกันบนเว็บเพจ ซึ่งช่วยให้การปรับปรุงแก้ไขเว็บเพจนั้นทำได้ง่าย ไม่ต้องมีความรู้ในภาษา HTML
2. มีเครื่องมือในการช่วยสร้างรูปแบบหน้าจอเว็บเพจ และมีความยืดหยุ่นในการใช้งานสูง
3. สนับสนุนภาษาสคริปต์ต่าง ๆ ทั้งฝั่งไคล์เอ็นต์ และเซิร์ฟเวอร์ เช่น Java, ASP, PHP, CGI, VBScript 
4. มีเครื่องมือในการอัพโหลด (Upload) หน้าเว็บเพจไปที่เครื่องเซิร์ฟเวอร์เพื่อทำการเผยแพร่งานที่เราสร้างในอินเทอร์เน็ต โดยการส่งผ่าน FTP หรือโดยการใช้โปรแกรมภายนอกช่วย
5. รองรับมัลติมีเดีย เช่นเสียง กราฟิก และอนิเมชั่นที่สร้างโดยโปรแกรม Flash, Shockwave, Firework เป็นต้น
6. มีความสามารถทำการติดต่อกับฐานข้อมูล เพื่อความสะดวกในการเขียนแอพพลิเคชั่น บนเว็บไซต์ 

เมื่อคุณได้ติดตั้งโปรแกรม Dreamweaver MX แล้วก็สามารถเรียกใช้งานโปรแกรมได้ ด้วยวิธีการดังต่อไปนี้


1. คลิกเมาส์ที่ปุ่ม 
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3. สักครู่ก็จะปรากฎหน้าต่างแรกของโปรแกรม Dreamweaver MX
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เป็นส่วนที่ใช้แสดงเนื้อหาในหน้าเว็บเพจที่เรากำลังทำงานอยู่ ซึ่งประกอบไปด้วย
	Title bar
	แถบชื่อโปรแกรม

	Toolbar
	แถบคำสั่ง รวบรวมปุ่มคำสั่งที่ใช้งานบ่อย

	Menu bar
	แถบคำสั่ง เป็นแถบที่ใช้เก็บคำสั่งทั้งหมดของโปรแกรม

	Objects Palette
	หน้าต่างออบเจ็กต์ กลุ่มเครื่องมือที่จะนำมาสร้างเป็นหน้าเว็บเพจ

	Document Window
	พื้นที่สำหรับสร้างหน้าเว็บ

	Properties Inspector
	หน้าต่าง Properties แสดงคุณสมบัติต่างๆของวัตถุ 

	Launcher
	รวบรวมไอคอนที่ใช้ เปิด/ปิด หน้าต่างการทำงานพิเศษ 

	Tag Selector
	ใช้สำหรับแสดงการทำงานกับส่วนโค๊ดที่เราต้องการ


Menu Bar

Menu Bar เป็นแถบคำสั่งที่ใช้เก็บคำสั่งทั้งหมดของโปรแกรม
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Document Toolbar 

ประกอบไปด้วยปุ่มที่ใช้กำหนดรูปแบบมุมมองของ Document Window ที่เรากำลังทำงานอยู่ และคำสั่งต่างๆ ที่ใช้ทำงานกับ Document Window ซึ่งมีการทำงานดังนี้
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	เป็นปุ่มที่ใช้สลับมุมมอง จากมุมมองอื่นๆ มาเป็นมุมมองโค๊ด 

	[image: image6.png]



	เป็นปุ่มที่ใช้สลับมุมมอง จากมุมมองอื่นๆ มาเป็นมุมมองออกแบบและมุมมองโค๊ด 

	[image: image7.png]



	เป็นปุ่มที่ใช้สลับมุมมอง จากมุมมองอื่นๆ มาเป็นมุมมองออกแบบ
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	เป็นปุ่มที่ใช้แสดงเนื้อหาในเว็บเพจที่ถูกดึงขึ้นมาจากฐานข้อมูล
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	เป็นฟิลด์ที่ให้กรอกชื่อของเว็บเพจ
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	เป็นปุ่มที่ใช้เปิดไดอะล็อก Design Note ที่ใช้เก็บข้อมูลของเว็บเพจที่เราสร้างขึ้น
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	เป็นปุ่มที่ใช้เปิดป๊อปอัพเมนูเพื่อเลือกเว็บบราวเซอร์ที่จะเปิดไฟล์ที่เราทำงานอยู่มาแสดงผล
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	เป็นปุ่มที่ใช้ปรับการแสดงผลของเว็บเพจใหม่หลังจากที่เราแก้ไขโค๊ด HTML 
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	เป็นปุ่มที่ใช้เปิดพาเนล Referance 
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	เป็นปุ่มที่ใช้แสดงป๊อปอัพเมนูที่เก็บคำสั่งที่ใช้ทดลองการทำงานของจาวาสคริปต์ที่อยู่ในเว็บเพจ
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	เป็นปุ่มที่ใช้แสดงป๊อปอัพเมนูที่เก็บคำสั่งที่ใช้ปรับการแสดงผลของ Duocument Window


Tag Selector

อยู่ใน Status Bar ที่อยู่ด้านล่างของ Document Window เมื่อเราคลิกวัตถุในเอกสาร จะปรากฎ Tag Selector ใน Status Bar ขึ้นมา ซึ่งช่วยให้ง่ายต่อการทำงาน
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Launcher Bar

Launcher Bar จะรวบรวมไอคอนที่ใช้เปิด/ปิดหน้าต่างการทำงานที่ใช้บ่อยๆ ในโปรแกรม 
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	เป็นปุ่มที่ใช้เปิดพาเนล Site
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	เป็นปุ่มที่ใช้เปิดพาเนล Assets 
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	เป็นปุ่มที่ใช้เปิดพาเนล CSS Style
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	เป็นปุ่มที่ใช้เปิดพาเนล Behavior 
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	เป็นปุ่มที่ใช้เปิดพาเนล History 

	[image: image23.png]



	เป็นปุ่มที่ใช้เปิดพาเนล Blindings 
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	เป็นปุ่มที่ใช้เปิดพาเนล Server Behavior
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	เป็นปุ่มที่ใช้เปิดพาเนล Components 
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	เป็นปุ่มที่ใช้เปิดพาเนล Database 


Properties Inspector
ใช้แสดงคุณสมบัติต่างๆ ของวัตถุ หรือข้อความที่เราเลือกในเว็บเพจ เราสามารถที่จะเปลี่ยนแปลงแก้ไขคุณลักาณะต่างๆ ได้โดยผ่านทาง Properties Inspector

* เป็น Propertries ที่แสดงคุณสมบัติต่างๆ ของข้อความ
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* เป็น Propertries ที่แสดงคุณสมบัติต่างๆ ของรูปภาพ เมื่อเราคลิกที่รูปภาพที่ต้องการจะปรับแต่ง
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การกำหนดรายละเอียดของหน้าเว็บ
ก่อนที่เราจะทำในเรื่องของเนื้อหา เราควรเริ่มในส่วนของการกำหนดรายละเอียดของหน้าเว็บก่อน โดย
1. คลิกเมาส์ปุ่มขวา เลือกคำสั่ง Page Properties  หรือเลือกจากเมนู Modify > Page Properties (หรือกด Ctrl + J)

2. เรากำหนดรายละเอียดของหน้าต่างเว็บเพจ จากหน้าต่าง Page Properties
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	Title
	กำหนดหัวเรื่องของหน้าเว็บ

	Background Image
	กำหนดภาพที่ใช้เป็นฉากหลังของหน้าเว็บ

	Background
	กำหนดสีที่ต้องการให้เป็นพื้นหลังของหน้าเว็บ

	Text Links, Visited Links, Active Links
	กำหนดสีให้กับลิงค์แบบต่างๆ 

	Left Margin
	กำหนดระยะขอบซ้ายของหน้าเว็บ Explorer 

	Top Margin
	กำหนดระยะขอบบนของหน้าเว็บ Explorer 

	Margin Width
	กำหนดระยะขอบซ้ายของหน้าเว็บ Netscape

	Margin Height
	กำหนดระยะขอบซ้ายของหน้าเว็บ Netscape 

	Document Encoding
	กำหนดชุดตัวอักษรที่ต้องการใช้

	Tracing Image, Image Transparency
	ใช้กำหนดภาพที่จะใช้อ้างอิงหรือใช้เป็นเทมเพลต


การแทรกตัวอักษร
เราสามารถพิมพ์ข้อความเข้าไปในเว็บเพจได้คล้ายกับพิมพ์ในโปรแกรม Word ทั้งยังสามารถจัดรูปแบบให้เกิดความสวยงาม สามารถเติมสีให้กับตัวอักษรได้ ทำให้ให้เว็บเพจของเราสวยงาม และน่าสนใจ
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การขึ้นย่อหน้าใหม่
สามารถทำได้โดยการกด Enter ซึ่งวิธีนี้จะมีการแทรกบรรทัดว่างก่อนเริ่มและหลังย่อหน้า
การแทรก Line Break
วิธีนี้เป็นการขึ้นบรรทัดใหม่แต่ไม่เว้นช่องว่างเหมือนกับการขึ้นย่อหน้าใหม่ โดยกด Shift + Enter หรือคลิกที่ปุ่ม BR ในหน้าต่างออบเจ็กต์
แทรกที่ว่างระหว่างตัวอักษร
ในการพิมพ์ข้อความในหน้าเว็บ เมื่อเราต้องการให้เกิดช่องว่างระหว่างตัวอักษรมากๆ เราไม่สามารถเคาะ Space bar เหมือนกับ โปรแกรม Word ได้ แต่วิธีที่สามารถจะทำได้นั่นก็คือ กด Ctrl + Shift + Space bar หรือกดปุ่ม  [image: image31.png][



  Non-Breaking ช่องว่างระหว่างตัวอักษรจะเพิ่มขึ้นตามจำนวนที่เราคลิก 
การจัดรูปแบบข้อความ
เราสามารถจัดรูปแบบและขนาดของตัวอักษรได้ตามที่ต้องการจากหน้าต่าง Properties 
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	Format
	รูปแบบของตัวอักษร 
	

	
	None
	ไม่กำหนดรูปแบบ

	
	Paragraph
	ข้อความในย่อหน้า

	
	Heading
	หัวข้อ (Heading 1 จะเป็นตัวอักษรที่มีขนาดใหญ่ที่สุด)

	
	Performatted
	ให้แสดงข้อความที่พิมพ์ตามรูปแบบที่จัดไว้แล้ว

	Font
	รูปแบบตัวอักษร
	

	Size
	ขนาดของตัวอักษร
	

	Color
	สีของตัวอักษร
	


การใส่รูปภาพลงในเว็บเพจ
เราสามารถใส่รูปภาพลงในเว็บเพจ โดยเมื่อเราใส่รูปภาพลงไปในเว็บเพจ โปรแกรม Dreamweaver จะสร้างโค๊ด HTML ที่อ้างถึงไฟล์ภาพดังกล่าวให้โดยอัตโนมัติ เพื่อให้การทำงานเป็นไปอย่างถูกต้องไฟล์รูปภาพที่ใส่ลงไปควรจะมีเก็บไว้ในเว็บไซต์ด้วย ขั้นตอนในการใส่รูปภาพลงในเว็บเพจ
1. เลือกตำแหน่งที่ต้องการจะใส่รูปภาพ
2. เลือกคำสั่ง Insert > Image หรือ คลิกเมาส์ที่ไอคอน  [image: image33.png]


 ในหน้าต่างออบเจ็กต์ หรือกด Ctrl + Alt + I

3. เลือกรูปภาพที่ต้องการแล้วกด OK
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4. จะปรากฎรูปภาพบนหน้าจอเว็บเพจ
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การแสดงภาพเป็นพื้นหลังเว็บเพจ
เราสามารถนำภาพมาทำเป็นพื้นหลังของเว็บเพจได้ แต่ภาพที่นำมาใช้ไม่ควรมีสีเข้มเพราะจะทำให้ข้อความรกตา อ่านยาก วิธีการนำภาพมาเป็นพื้นหลัง
1. เลือกคำสั่ง Modify > Page Properties หรือกด Ctrl + J
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2. คลิกเมาส์ที่ปุ่ม เพื่อกำหนดรูปที่จะนำมาใช้ หลังช่อง Background Image 
3. เลือกไฟล์ภาพที่ต้องการนำมาใช้
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4. จะได้ภาพที่นำมาเป็นพื้นหลังของเว็บเพจ
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การสร้างตาราง
การนำตารางมาใช้ในการสร้างงานในเว็บเพจช่วยจัดองค์ประกอบต่างๆ ให้อยู่ในตำหน่งที่ต้องการ ได้อย่างเป็นสัดส่วน ช่วยให้ข้อมูลดูเป็นระเบียบเรียบร้อย และยังสามารถที่จะแทรกภาพลงในตารางได้ด้วย 
การสร้างตารางทำได้ 3 วิธี คือ
1. เลือกเมนู Insert > Table หรือ เลือกออบเจ็กต์ จากหน้าต่างออบเจ็กต์ ( Window > Insert จะปรากฎหน้าต่างออบเจ็กต์ขึ้นดังรูป)


2. กดคีย์ Ctrl + Alt + T
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โดยทั้ง 3 วิธีจะแสดงไดอะล็อกบ็อกซ์ Insert Table สำหรับกำหนดรายละเอียดตาราง
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	Rows
	จำนวนแถวที่ต้องการ

	Columns 
	จำนวนคอลัมน์ที่ต้องการ

	Width
	ความกว้างของตาราง หน่วยที่ใช้เป็นเปอร์เซ็นต์หรือพิกเซลก็ได้

	Border
	ความหนาของขอบตาราง

	Cell Padding
	ระยะระหว่างข้อความในตารางกับขอบตาราง

	Cell Spacing 
	ระยะระหว่างแต่ละเซลล์ในตาราง


เมื่อเรากำหนดรายละเอียดใน Insert Table เรียบร้อยแล้ว คลิกปุ่ม OK ก็จะได้ตารางตามที่เรากำหนดดังรูปข้างล่าง
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ใส่ข้อมูลในตาราง 
ในการใส่ข้อมูลลงในตาราง เราสามารถทำได้โดยคลิกเลือกช่องเซลล์ที่ต้องการแล้วพิมพ์ข้อความใส่ลงไปได้เลย โดยสามารถใส่สีพื้นหลังของตาราง ใส่ตารางซ้อนตาราง และรูปภาพลงในตารางได้
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การจัดเรียงข้อความในตาราง 
จัดข้อมูลในแนวนอน
เราสามารถจัดข้อมูลให้ชิดขวา ชิดซ้าย หรืออยู่ตรงกึ่งกลางของช่องตาราง โดยการคลิกในช่องเซลล์ที่ต้องการ แล้วกำหนดในช่อง Horz ในแถบ Properties (Window > Properties > Horz)


1. คลิกในช่องเซลล์ที่ต้องการ แล้วกำหนดในช่อง Horz ในแถบ Properties


2. เมื่อเลือกในช่อง Horz แล้วจะได้ตำแหน่งของข้อความตามที่เราต้องการ
	Default
	เป็นการจัดเรียงข้อมูลแบบปกติ (คือจัดให้อยู่ชิดซ้ายของช่องตาราง)

	Left 
	จัดให้ข้อมูลอยู่ชิดซ้ายของช่องตาราง

	Right
	จัดให้ข้อมูลอยู่ชิดขวาของช่องตาราง

	Center
	จัดให้ข้อมูลอยู่กึ่งกลางของช่องตาราง


จัดข้อมูลในแนวตั้ง
ถ้ามีช่องตารางที่ขยายออกมามากกว่า 1 แถวเราสามารถกำหนดข้อมูลนั้นให้ชิดด้านบน ด้านล่าง หรือกึ่งกลางได้ โดยการคลิกที่ช่องเซลล์ที่ต้องการแล้วกำหนด Vert ในแถบ Properties (Window > Properties > Vert)


1. คลิกเลือกช่องเซลล์ที่ต้องการ แล้วกำหนดใช่อง Vert ในแถบ Properties


2. เมื่อเลือกในช่อง Vert แล้วจะได้ตำแหน่งของข้อความตามที่เราต้องการ
	Default
	เป็นการจัดเรียงแบบปกติของข้อมูล (คือจัดให้อยู่กึ่งกลางของช่องตาราง)

	Top
	จัดให้ข้อมูลอยู่บนสุดของช่องตาราง

	Middle
	จัดให้ข้อมูลอยู่กึ่งกลางของช่องตาราง

	Bottom
	จัดให้ข้อมูลอยู่ล่างสุดของช่องตาราง

	Baseline
	ข้อมูลบรรทัดสุดท้ายจะติดกับขอบเซลล์เส้นล่างสุด


การเชื่อมโยง
การเชื่อมโยงหน้าเว็บเพจในอินเทอร์เน็ตเข้าด้วยกัน เป็นสิ่งที่ทำให้เว็บเพจมีความ แตกต่างจากเอกสารธรรมดา เพราะมันทำให้ผู้ใช้ไม่ต้องเปิดดูตั้งแต่หน้าแรก แต่สามารถ Click mouse เปิดดูเฉพาะหน้าเว็บเพจที่สนใจได้ สำหรับในบทนี้เราจะกล่าวถึงการเชื่อมโยงข้อมูลในเว็บเพจเข้า ด้วยกัน 
การเชื่อมโยงแบบต่าง ๆ
การเชื่อมโยงบนเว็บเพจมีด้วยกันหลายรูปแบบ อาจแบ่งตามการใช้งาน หรือตามลักษณะของการเชื่อมโยงก็ได้ ถ้าแบ่งตามลักษณะการเชื่อมโยงจะแบ่งการเชื่อมโยงออกเป็น 2 ประเภท คือ การเชื่อมโยงภายในเว็บเพจ และการเชื่อมโยงภายนอกเว็บเพจ แต่ถ้าแบ่งตามวัตถุประสงค์ของรูปแบบการใช้งานจะแบ่งการเชื่อมโยงบนเว็บเพจออกเป็นประเภทต่าง ๆ ดังต่อไปนี้
1. การเชื่อมโยงภายในเว็บเพจเดียวกัน
2. การเชื่อมโยงภายในเว็บเพจไซต์เดียวกัน
3. การเชื่อมโยงไปยังเว็บไซต์อื่น
4. การเชื่อมโยงด้วยอีเมล์
5. การเชื่อมโยงไปยังไฟล์ดาวน์โหลด
6. การเชื่อมโยงด้วย Map Link
7. การสร้าง Rollover Image

กำหนดลักษณะของเพจใหม่ที่เชื่อมโยง
เมื่อมีการ Click ที่ Link เราสามารถกำหนดการเปิดหน้าเว็บที่เชื่อมโยงได้ เช่น ให้แสดงหน้าเว็บที่เชื่อมโยงในหน้าต่างบราวเซอร์ใหม่ หรือให้แสดงแทนหน้าเพจเดิม โดยกำหนดได้จากส่วนของ Target ที่แถบ Properties หรือเลือกได้จากเมนู Modify > Link Target ดังนี้
	- blank
	ให้เปิดเพจที่เชื่อมโยงในหน้าต่างบราวเซอร์ใหม่อีกหน้าต่าง

	- parent
	ให้เปิดเพจที่เชื่อมโยงในหน้าต่างบราวเซอร์เดิม

	- self
	ให้เปิดเพจที่เชื่อมโยงในเฟรมเดิม

	- top
	ให้เปิดเพจที่เชื่อมโยง ในหน้าต่างบราวเซอร์เดิม โดยจัดให้เต็มเฟรม
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การเซฟหน้าเว็บเพจ
เมื่อเราทำการสร้างเว็บเพจเสร็จเรียบร้อยเป็นที่พอใจแล้ว ให้ทำการเซฟไฟล์ โดยมีคำสั่งให้เลือกใช้ดังนี้
	File > Save
	เซฟไฟล์ในชื่อเดิม

	File > Save As
	เซฟไฟล์ในชื่อใหม่

	File > as Template
	เซฟไฟล์เป็นเทมเพลต

	File > All
	เซฟไฟล์ทั้งหมด


ขั้นตอนง่ายๆ ในการเซฟไฟล์มีดังนี้
1. เลือกเมนู File > Save หรือ Save As... หรือ Save as Template... หรือ Save All
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2. เลือกโฟลเดอร์ที่จะจัดเก็บไฟล์ ในช่อง Save in
3. ใส่ชื่อไฟล์ในช่อง File name แล้วกด Save
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การแสดงหน้าเว็บเพจ 
เมื่อเราสร้างเว็บไซต์เสร็จแล้วเราสามารถทดสอบเว็บไซต์ของเราได้ โดยแสดงที่ Browser โดยกดปุ่ม Preview ดังรูป หรือกดปุ่ม F12 
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เมื่อกดปุ่ม F12 หรือปุ่ม Preview  แล้วก็จะแสดงเว็บออกมา ดังรูป
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การสร้าง Template


Template ของโปรแกรม Dreamweaver ทำให้สามารถแบ่งรูปแบบของเอกสารนั้น ๆ ออกเป็นสองส่วน คือ ส่วนที่แก้ไขได้ (Editable Regions) และส่วนที่แก้ไขไม่ได้ (Non-Editable Regions) เอกสารที่สร้างจาก Template เดียวกนจะมีรูปแบบเหมือนกันหมด การสร้าง Template สามารถสร้างได้จากหน้าเอกสารว่าง ๆ หรือหน้าที่มีข้อมูลอยู่แล้ว ซึ่งรวมถึงหน้าเอกสารที่มีข้อมูล แบบไดนามิค เช่น ASP, ColdFusion, JSP หรือ PHP ก็ตาม
ขั้นตอนการสร้าง Template

1. ออกแบบหน้าเว็บเพจตามต้องการ โดยจะกำหนดให้ส่วนหัวและส่วนเมนูเป็น Template

2. คลิกเมนู File > Save as Template
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จากนั้นจะปรากฏหน้าต่าง Dreamweaver ขึ้นมา
3. คลิกปุ่ม Edit Sites… จะปรากฏหน้าต่าง Site Difinition ขึ้นมา
4. พิมพ์ชื่อเว็บไซต์ที่ต้องการลงในช่อง What would you like to name your site?

5. คลิกปุ่ม Next เพื่อผ่านไปยังขั้นตอนต่อไป
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6. คลิกเลือก No, I do not want to use a server technology. เนื่องจากเราจะสร้างเว็บไซต์โดยจะไม่ใช้งานอะไรเกี่ยวข้องกับ Server

7. คลิกปุ่ม Next
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8. คลิกเลือกรายการแรก นั่นคือ Edit local copies on my machine, then upload to server when ready (recommended) เพื่อเลือกที่จะเก็บเว็บไซต์ที่สร้างไว้ในเครื่องของเราก่อน เมื่อพร้อมแล้วจึงจะอัพโหลดขึ้นไปยัง server

9. กำหนดโฟลเดอร์สรหรับเก็บเว็บไซต์ที่จะสร้างขึ้น ในช่อง Where on your computer do you want to store your files?

10. คลิกปุ่ม Next
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จากนั้นหน้าต่าง Choose Remote Root Folder จะปรากฏขึ้นมา ให้เลือกตำแหน่งที่ต้องการจะเก็บไฟล์
11. คลิกวิธีการเชื่อมต่อกับ server ที่ช่อง How do you connect to your remote server? โดยในตัวอย่างรายการ Local/Network เนื่องจากเชื่อมต่ออินเตอร์เน็ตผ่านระบบเครือข่ายภายในองค์กร
12. [image: image63.png]


คลิกปุ่ม        เพื่อเลือกโฟลเดอร์ทางฝั่ง server ที่จะอัพโหลดไฟล์ขึ้นไปเก็บไว้ในช่อง What folder on your server do you want to store your files in?

13. คลิกเลือกโฟลเดอร์ที่จะเก็บไฟล์
14. คลิกปุ่ม Select
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15. คลิกเลือก No, do not enable check in and check out.

16. คลิกปุ่ม Next

17. คลิกปุ่ม Done
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18. คลิกปุ่ม Cancel เพื่อปิดหน้าต่าง Save As Template ที่ปรากฏขึ้นมาก่อน
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การกำหนดส่วนแก้ไขและคงที่ของ Template


จากนั้นเราจะมากำหนดส่วนที่สามารถแก้ไขข้อมูลได้ และไม่สามารถแก้ไขข้อมูลได้ของเท็มเพลตนี้ก่อน โดยในที่นี้จะกำหนดให้ส่วนที่สามารถแก้ไขข้อมูลได้ก็คือ ส่วนที่เป็นรูปภาพและส่วนที่เป็นข้อความว่า Welcome

1. คลิกรูปภาพที่ต้องการจะกำหนดให้สามารถแก้ไขได้
2. คลิกรูปภาพ Insert > Template Objects > Editable Region หรือ Ctrl+Alt+V จะปรากฏหน้าต่าง New Editable Region ขึ้นมา
3. พิมพ์ชื่อของส่วนที่ต้องการให้แก้ไขได้ที่ช่อง Name จากตัวอย่างพิมพ์ว่า EditPicture01

4. คลิกปุ่ม OK
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5. สังเกตที่รูปภาพ จะมีข้อความว่า EditPicture01 แสดงอยู่
ถ้าต้องการกำหนดให้ส่วนที่เป็นข้อความว่า Welcome สามารถแก้ไขได้เหมือนรูปภาพก็ให้ทำตามขั้นตอนที่ 1-4 โดยตั้งชื่อใหม่ตามต้องการ ในที่นี้ตั้งชื่อเป็น EditText01 ก็จะได้หน้าเท็มเพลตที่เสร็จเรียบร้อยดังรูปด้านล่าง
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การบันทึก Template


ในกรณีที่ต้องการบันทึกหน้าเท็มเพลตที่สร้างขึ้น ให้ทำตามขั้นตอนดังแสดงต่อไปนี้
1. คลิกเมนู File > Save As Template… เพื่อบันทึกหน้าเว็บเพจ จะปรากฏหน้าต่าง Save As Template ขึ้นมา
2. กำหนดชื่อเท็มเพลตที่สร้างขึ้น ในช่อง Save As:

3. คลิกปุ่ม Save
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การเปิดหน้า Template


หลังจากที่สร้างหน้าเท็มเพลตเสร็จเรียบร้อยแล้ว และต้องการเปิดหน้าเท็มเพลตนั้นขึ้นมาใช้งาน มีวิธีการเปิดดังต่อไปนี้
1. คลิกเมนู File > New จะปรากฏหน้าต่าง New From Template ขึ้นมา
2. คลิกแท็บ Templates

3. คลิกเลือกไฟล์เท็มเพลตที่ต้องการ
4. คลิกปุ่ม Create
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จะปรากฏหน้าเท็มเพลตที่เลือกขึ้นมา โดยจะแสดงชื่อเท็มเพลตที่มุมบนด้านขวา โดยส่วนที่สามารถแก้ไขได้สัญลักษณ์ของเมาส์จะแสดงเป็นรูปเคอร์เซอร์ และส่วนที่ไม่สามารถแก้ไขข้อมูลได้นั้นสัญลักษณ์เมาส์จะไม่แสดงเครื่องหมายเคอร์เซอร์ขึ้นมา ดังรูปด้านล่าง
[image: image59.png]Macromedia Dreamweaver MX - [Untitled Document (Us -2*)]
) Fie Gt Vew Insert Mody Text Commands Ske Widow rip

[ 53 | elUnitedbonmen 0t @, | C <

» Design
» Code
» Application
~ Files

Home
History
Education
bout Me

.Template Sample

@elcome

Template: sample

Flee Edte Viows Siex
IR
[romoe =] [Lecavn =]

EIG Site- Template [C:\Template]
D Images
D Templates
124t
& 1t

template i

@
@ pesker

K1 — B

Dte: 3(8/2004 12:53 P

Learning Macromedia
Dreamweaver X

bt e

Uit

Crnlinstance fiinstances <head cminstance:edtable>

~ Properties

(803 483 - [59K /15 se

Readme
Tateria:
Update Panel

Gl Usdate fo connect fo
mosromediscom and get fh latest





การ Upload web ขี้น server 


ก่อนที่จะทำการ Upload เว็บนั้น เราจะต้องหาพื้นที่ที่จะทำการ Upload เว็บของเราขึ้น หากหน่วยงานไม่มี webserver ให้บริการ ก็จะต้องหา Host ที่ให้บริการ อาจะจะเช่า หรืออาจจะใช้พื้นที่ฟรีตามเว็บไซต์ทั่วไปเช่น www.geocities.com, www.thai.net, www.thaicity.com, เป็นต้น 

ในที่นี้จะใช้ webserver ของสถาบันเป็นตัวที่จะทำการ Upload เว็บที่ทำเสร็จแล้วขึ้นไป โดยใช้ใช้โปรแกรม CuteFTP Pro 3.0 เป็นตัว Upload ขึ้นไป

ให้เข้าโปรแกรม CuteFTP ก่อน
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โดยด้ายซ้ายมือจะเป็นข้อมูลที่จะทำการ Upload ด้านขวามือจะเป็น พื้นที่ที่อยู่บน webserver ให้คลิกที่ปุ่ม Connect ดังรูป
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Host : ใหใสชื่อ Url ของ server หรืออาจะเป็น ip ของ server

Name : ใส่ชื่อ username

Password : ใส่ password 


แล้วก็คลิก Connect (Username or password หากเป็นเว็บฟรีที่สมัครให้ใส่ตัวนี้เข้าไปได้เลย) เมื่อ connect เสร็จแล้วก็จะแสดงรายชื่อไฟล์ที่มีอยู่ใน server 
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เมื่อจะทำการ Upload file ให้เลือกไฟล์ที่จะทำการ Upload ซึ่งจะอยู่ทางด้านซ้ายมือ แล้วคลิกขวาที่ไฟล์ที่จะทำ upload แล้วคลิกคำว่า upload ไฟล์ที่ upload เสร็จเรียบร้อยก็จะมาอยู่ด้านขวามือของโปรแกรม






